Author Topic: [SOLVED] Mouse is slow in Full Screen, slider in WinSetup has no effect.  (Read 240 times)

Heyhey,
I'm testing my game in windowed mode mostly, so I only just now noticed that the mouse cursor is moving a lot slower when in full screen (after compilation with F7 and then "start and run" in winsetup).
I tried dialing up the mouse speed in the advanced winsetup, but it made no difference - I tried 1x, 3x and 10x, same speed. I found an old thread talking about mouse acceleration, but couldn't connect it t my issue - it seems people rather had the problem of the mouse going too fast in the past.
I tried this on my parents win7 and my win 10 desktop using the (Build 3.5.0.14) of AGS.


Best regards from Berlin,

Johannes
« Last Edit: 18 Jul 2019, 19:07 by cutmeat »

Cassiebsg

  • Cavefish
  • Fleeing the Cylon tyrrany...
    • Cassiebsg worked on one or more games that won an AGS Award!
    •  
    • Cassiebsg worked on one or more games that was nominated for an AGS Award!
I believe that when in windowed mode, the mouse speed is the same as adjusted in windows.

You can adjust mouse speed via code in the editor, for full screen only (I think) using mouse.Speed.
There are those who believe that life here began out there...

You can try disabling the managed cursor speed by setting this in the config file:
Code: INI
  1. [mouse]
  2. control=never

Thanks guys!
Unfortunately, I tried both methods, and couldn't get the mouse speed to change. I put this into my acsetup.cfg and started the game from the compiled exe:

Code: Adventure Game Studio
  1. [mouse]
  2. control=never
  3. auto_lock=0
  4. speed=1
  5.  


And I tried putting

Code: Adventure Game Studio
  1. mouse.Speed = 10.0;
  2.  

into game_start() with different values. As of yet I couldn't notice a change. What am I doing wrong? Thanks in advance!
« Last Edit: 18 Jul 2019, 17:45 by cutmeat »

Just grasping at straws here, but do you have VSync on by any chance? I find that in certain computers it makes my frames drop like crazy and the mouse feels kind of sluggish...

Mhm, thanks, I'll have a look.  It's not like my game is running sluggishly or lagging though, it's just the "slow" mouse. By that I mean that moving my physical mouse doesn't move the cursor a whole lot.
Also, not unplayably so, but it's still ruining the experience in my view. I just set the winsetup slider to 0.1, and still no difference, it's not going EVEN slower or anything.

EDIT: Alright, so I just tested it adjusting the windows Mouse speed... and that has an effect. While my mouse speed is perfect for using the desktop, for some reason it is a lot slower when running the program... By that I don't mean that I perceive it differently, it IS different, but still controlled by Windows. Maybe this has to do with the resolution somehow? I'll keep testing.

EDIT2: This turned out to be true. My game resolution is 384 x 216, which is HD-aspect ratio. Winsetup is usually set to my desktop resolution of 2560 x 1440, and "Stretch, maintaining aspect ratio". If I set it to 640x480 for example, and lose the aspect ration and image quality, then the mouse moves faster again. Mhm.

EDIT3: [SOLUTION] I found the second "acsetup.cfg" in my user profile under "Saved Games"... the one that is actually used for the game... In it, for some reason, there was a setting:
Code: Adventure Game Studio
  1. [mouse]
  2. control_enabled = 0
  3.  

Setting this to 1 let me control mouse speed via the slider in winsetup again, so that the windows mouse config and resolution stuff all became irrelevant. I haven't yet found how to set this in the editor, or whether I or some script I'm using set this when I started with the game :/

« Last Edit: 18 Jul 2019, 19:07 by cutmeat »

EDIT3: [SOLUTION] I found the second "acsetup.cfg" in my user profile under "Saved Games"... the one that is actually used for the game... In it, for some reason, there was a setting:
Code: Adventure Game Studio
  1. [mouse]
  2. control_enabled = 0
  3.  

Setting this to 1 let me control mouse speed via the slider in winsetup again, so that the windows mouse config and resolution stuff all became irrelevant. I haven't yet found how to set this in the editor, or whether I or some script I'm using set this when I started with the game :/

This may be an issue with recent 3.5.0 version. I recently added "Mouse.ControlEnabled" to the script to support some games made with custom engine, and it also saves last value to config. But maybe the logic behind this is flawed and need to be revisited.


Also, I need to tell that in latest 3.5.0 another option has changed its name. If you want to disable control fully you now need to do:
Code: Text
  1. [mouse]
  2. control_when=never
  3.  
instead of "control=never"

Alright. Just wanted to mention that after changing the setting by hand on my work PC, at home I got lazy and just deleted the acsetup.cfg in Saved Games... it was automatically rebuilt when starting my game from the EXE, WITHOUT the line "control_enabled = 0", and my mouse control worked. I don't understand it, but it's working now anyway.